Haveing trouble getting Client running with Ubunto 16.04

Message boards : BOINC client : Haveing trouble getting Client running with Ubunto 16.04
Message board moderation

To post messages, you must log in.

AuthorMessage
Martin Glazer

Send message
Joined: 31 Aug 16
Posts: 6
United States
Message 72594 - Posted: 22 Sep 2016, 21:08:14 UTC

HI
I am having trouble getting the BOINC client running again, under Ubunto 16.04
I installed it from the command line. I can see the program installed in the BOINC directory. I don't want to install BOINC from apt-get because it always installs the old version of the client (naturally).
I can see the boinc and the run_client and the run_manager in the directory. I cant run the program to start the client?
Can anyone help me with this?

Thanks
ID: 72594 · Report as offensive
SekeRob2
Volunteer tester
Help desk expert

Send message
Joined: 6 Jul 10
Posts: 585
Italy
Message 72601 - Posted: 23 Sep 2016, 7:29:38 UTC - in response to Message 72594.  
Last modified: 23 Sep 2016, 7:46:57 UTC

Theoretically, this does the trick for me (will ask for your password so it can run at elevated permissions)

sudo service boinc-client start

Gianfranco Costamagna always has the latest build, now 7.6.32 dbfg on his ppa. Go (debian package maintainer) https://launchpad.net/~costamagnagianfranco, click on Boinc development release. The ppa shown there is the one to add to your software repositories. This is a meta package, which sets it all and launches the core client/daemon on boot, before you sign in. Been using his since years and years, prompt to fix package issues.

Don't know why there has not been an official build for Linux since September 2014 on the official Berkeley download page, but 7.4.22 looks pretty ancient, Win/OS-X are on 7.6.22 recommended.
Coelum Non Animum Mutant, Qui Trans Mare Currunt
ID: 72601 · Report as offensive
Profile Agentb
Help desk expert
Avatar

Send message
Joined: 30 May 15
Posts: 265
United Kingdom
Message 72603 - Posted: 23 Sep 2016, 9:01:34 UTC - in response to Message 72601.  
Last modified: 23 Sep 2016, 9:09:21 UTC

SekeRob2 wrote:
Don't know why there has not been an official build for Linux since September 2014 on the official Berkeley download page, but 7.4.22 looks pretty ancient, Win/OS-X are on 7.6.22 recommended.


Yes it is two years old.

boinc is running at 7.6.31 on 16.04 LTS since 12 May 2016 so the normal method of installing software will get that. See https://launchpad.net/ubuntu/xenial/+source/boinc

At 16.04 ubuntu has moved to systemd so the correct interface to start and stop services is systemctl although the old init scripts do work (assuming that boinc is installed as a service)

systemctl status boinc-client.service
systemctl restart boinc-client.service


Perhaps the OP might provide some help about what boinc version was running and the errors, see "When requesting help" in the Questions and Problems forum.
ID: 72603 · Report as offensive

Message boards : BOINC client : Haveing trouble getting Client running with Ubunto 16.04

Copyright © 2017 University of California. Permission is granted to copy, distribute and/or modify this document under the terms of the GNU Free Documentation License, Version 1.2 or any later version published by the Free Software Foundation.